Correção dos Exercícios: A Estrutura de um Programa

Imagem da tela de um notebook com códigos. Imagem usada como capa para os posts de solução de exercícios.

No post anterior, eu havia proposto cinco exercícios com o objetivo de você praticar a criação da estrutura básica de um programa em Portugol e, também, o comando de escrever na tela. Pois bem, segue a correção dos exercícios para que você possa comparar as suas soluções com as que eu fiz.

Exercício 1

Código para download: GitHub

programa
{
	funcao inicio()
	{
		escreva("    Nome: Maria José\n")
		escreva("   Idade: 28 anos\n")
		escreva("Telefone: (11) 9.5555-5555\n")
		escreva("     Rua: Rua dos Bobos\n")
		escreva("  Número: Zero\n")
		escreva("     CEP: 12345-678")
	}	
}

Exercício 2

Código para download: GitHub

programa
{
	funcao inicio()
	{
		escreva("+----------------+\n")
		escreva("|  ##  ##  ##  ##|\n")
		escreva("|##  ##  ##  ##  |\n")
		escreva("|  ##  ##  ##  ##|\n")
		escreva("|##  ##  ##  ##  |\n")
		escreva("|  ##  ##  ##  ##|\n")
		escreva("|##  ##  ##  ##  |\n")
		escreva("|  ##  ##  ##  ##|\n")
		escreva("|##  ##  ##  ##  |\n")
		escreva("+----------------+\n")
	}
}

Exercício 3

Código para download: GitHub

programa
{
	funcao inicio()
	{
		escreva(" X | O |   \n")
		escreva("---+---+---\n")
		escreva("   | X |   \n")
		escreva("---+---+---\n")
		escreva("   |   | O ")
	}
}

Exercício 4

Código para download: GitHub

programa
{
	funcao inicio()
	{
		escreva("% de aumento |  2010 |  2011 \n")
		escreva("-------------+-------+-------\n")
		escreva("     Marca A |  4.5% |  7.5% \n")
		escreva("     Marca B | 14.5% | 23.5% ")
	}
}

Exercício 5

QR-Code com linhas dividindo e evidenciando cada um dos "quadradrinhos"

Código da versão 1 para download: GitHub

programa
{
	funcao inicio()
	{
		escreva("####### ##  # #######\n")
		escreva("#     #  #  # #     #\n")
		escreva("# ### # # # # # ### #\n")
		escreva("# ### # #  #  # ### #\n")
		escreva("# ### # ###   # ### #\n")
		escreva("#     #       #     #\n")
		escreva("####### # # # #######\n")
		escreva("         ##          \n")
		escreva("####  # # #  #  ### #\n")
		escreva("#   #  ###  ##  ##  #\n")
		escreva(" # #  # # # #### # ##\n")
		escreva("# ####    # #  #### #\n")
		escreva("##    ##   #  # # ###\n")
		escreva("        ## # #   #  #\n")
		escreva("#######  #   ######  \n")
		escreva("#     #    ### #     \n")
		escreva("# ### #  # #     ### \n")
		escreva("# ### # #   #      # \n")
		escreva("# ### # ##  #  # ##  \n")
		escreva("#     # #   ###  #  #\n")
		escreva("####### # ######  #  \n")
	}
}

Código da versão 2 para download: GitHub

programa
{
	funcao inicio()
	{
		escreva("##############  ####    ##  ##############\n")
		escreva("##          ##    ##    ##  ##          ##\n")
		escreva("##  ######  ##  ##  ##  ##  ##  ######  ##\n")
		escreva("##  ######  ##  ##    ##    ##  ######  ##\n")
		escreva("##  ######  ##  ######      ##  ######  ##\n")
		escreva("##          ##              ##          ##\n")
		escreva("##############  ##  ##  ##  ##############\n")
		escreva("                  ####                    \n")
		escreva("########    ##  ##  ##    ##    ######  ##\n")
		escreva("##      ##    ######    ####    ####    ##\n")
		escreva("  ##  ##    ##  ##  ##  ########  ##  ####\n")
		escreva("##  ########        ##  ##    ########  ##\n")
		escreva("####        ####      ##    ##  ##  ######\n")
		escreva("                ####  ##  ##      ##    ##\n")
		escreva("##############    ##      ############    \n")
		escreva("##          ##        ######  ##          \n")
		escreva("##  ######  ##    ##  ##          ######  \n")
		escreva("##  ######  ##  ##      ##            ##  \n")
		escreva("##  ######  ##  ####    ##    ##  ####    \n")
		escreva("##          ##  ##      ######    ##    ##\n")
		escreva("##############  ##  ############    ##    \n")
	}
}

Código da versão 3 para download: GitHub

Página da Wikipedia que fala sobre os caracteres ASCII que eu comento no vídeo: Code Page 850. E, se quiser saber mais sobre Arte ASCII, acesse esse site: ASCII Art Archive.

4 Comments on “Correção dos Exercícios: A Estrutura de um Programa
  1. Olá, o curso continuará, ótima didática a sua, parabéns!!

    Estou em um curso tecnico de informática integrado com o ensino medio, e ano q vem (segundo ano), iremos começar a trabalhar com os algoritmos, e o professor disse para já irmos praticando durante as férias, e foi assim que encontrei esse site, muito bom por sinal !!

Participe deixando seu comentário!